====== Alternate rootvg ======
* Split du rootvg
bosboot -a
unmirrorvg rootvg hdisk1
reducevg rootvg hdisk1
alt_disk_copy -d hdisk1
bootlist -m normal hdisk0
* Suppression du alt_rootvg si tout est ok
alt_rootvg_op -X altinst_rootvg
extendvg -f rootvg hdisk1
mirrorvg rootvg hdisk1
bootlist -m normal -o hdisk0 hdisk1
* Activation du alt_rootvg comme master (si upgrade KO)
bootlist -m normal -o hdisk1
shutdown -Fr
alt_rootvg_op -X altinst_rootvg
extendvg –f rootvg hdisk1
mirrorvg rootvg hdisk1
bootlist -m normal -o hdisk0 hdisk1
bosboot -a
====== Installer un ifix - efix ======
emgr -e IY95543.070301.epkg.Z
====== Monter un cd ======
mount -Vr cdrfs /dev/cd0 /cdrom
====== Monter une ISO ======
* **AIX 5.1**
mklv -y cdlv -s n -L /dev/cdlv rootvg 700M hdisk0
dd if=/install/image.iso of=/dev/cdlv bs=32k
mount -v cdrfs -o ro /dev/cdlv /mnt
* **AIX 6.1**
loopmount -i /install/image.iso -o "-V cdrfs -o ro" -m /mnt
====== Rechercher un APAR ======
http://www-1.ibm.com/support/
====== Activer les IO asynchrones sans rebooter ======
chdev -l aio0 autoconfig=available
mkdev -l aio0
====== Mofidier la longueur max. des logins ======
//AIX 5.3 only//
lsattr -El sys0 -a max_logname
chdev -l sys0 -a max_logname=XX (XX--desired number)
lsattr -El sys0 -a max_logname
getconf LOGIN_NAME_MAX
shutdown -Fr
====== Packages ======
lslpp -L displays info about all installed filesets or fileset updates
lslpp -L displays info about that fileset
lslpp -h shows the history of the fileset
lslpp -l | grep shows if it is installed or not
lslpp -lc| grep shows the state (Aplp., Comm., Broken..) in /etc/objrepos and in /usr/lib/objrepos of a fileset
lslpp -f shows all files that are installed with a particular fileset
lslpp -w /usr/local/bin/lsof shows the fileset which contains the given file (binary) (which command shows full path: which lsof)
lslpp -p shows requisite information for a specified fileset (-p means possibly prerequisite)
lslpp -d shows filesets that are dependents on the specified fileset