informatique:nix:solaris:solaris_net

# ndd -set /dev/qfe instance 0
# ndd -get /dev/qfe link_status
1 = up
0 = down
# ndd -get /dev/qfe link_speed
1 = 100 Mb
0 = 10 Mb
# ndd -get /dev/qfe link_mode
1 = Full Duplex (FDX)
0 = Half Duplex (HDX)
ndd -set /dev/bge0 adv_1000fdx_cap 0
ndd -set /dev/bge0 adv_1000hdx_cap 0
ndd -set /dev/bge0 adv_100fdx_cap 1
ndd -set /dev/bge0 adv_100hdx_cap 0
ndd -set /dev/bge0 adv_10fdx_cap 0
ndd -set /dev/bge0 adv_10hdx_cap 0
ndd -set /dev/bge0 adv_autoneg_cap 0

Agrégat

  • Lister agrégats
root@server # dladm show-aggr   
key: 20 (0x0014)        policy: L4      address: 0:b:5d:e0:53:73 (auto)
           device       address                 speed           duplex  link    state
           bge1         0:b:5d:e0:53:73   1000  Mbps    full    up      attached
           bge3         0:b:5d:e0:53:f5   1000  Mbps    full    up      attached
key: 21 (0x0015)        policy: L4      address: 0:21:28:1d:a5:31 (auto)
           device       address                 speed           duplex  link    state
           nxge1        0:21:28:1d:a5:31          1000  Mbps    full    up      attached
           nxge5        0:14:4f:d9:c6:c7          1000  Mbps    full    up      attached
key: 30 (0x001e)        policy: L4      address: 0:14:4f:d9:c6:c9 (auto)
           device       address                 speed           duplex  link    state
           nxge7        0:14:4f:d9:c6:c9          1000  Mbps    full    up      attached
           nxge6        0:14:4f:d9:c6:c8          1000  Mbps    full    up      attached
key: 31 (0x001f)        policy: L4      address: 0:21:28:1d:a5:33 (auto)
           device       address                 speed           duplex  link    state
           nxge3        0:21:28:1d:a5:33          1000  Mbps    full    up      attached
           nxge2        0:21:28:1d:a5:32          1000  Mbps    full    up      attached
  • Stats agrégats
root@server# dladm show-aggr -s

key:20          ipackets   rbytes       opackets   obytes       %ipkts  %opkts
        Total   21617095879 2321186945738 64544133003 96271007632446
        bge1    13179326005 1147189792850 53612650880 79787108757923   61.0    83.1  
        bge3    8437769874 1173997152888 10931482123 16483898874523   39.0    16.9  

key:21          ipackets   rbytes       opackets   obytes       %ipkts  %opkts
        Total   84806046   6798759637   21598709   1641501884  
        nxge1   42849994   3560266936   21598709   1641501884     50.5   100.0  
        nxge5   41956052   3238492701   0          0              49.5     0.0  

key:30          ipackets   rbytes       opackets   obytes       %ipkts  %opkts
        Total   413518546  381397969548 325310049  134555602569
        nxge7   207432804  192957340454 183206181  62483858615    50.2    56.3  
        nxge6   206085742  188440629094 142103868  72071743954    49.8    43.7  

key:31          ipackets   rbytes       opackets   obytes       %ipkts  %opkts
        Total   52043801   3378360916   46686337   3548161612  
        nxge3   25344450   1648996443   46686337   3548161612     48.7   100.0  
        nxge2   26699351   1729364473   0          0              51.3     0.0

Boot réseau

{0} ok devalias
{0} ok boot net[0,1,2,x]:[dhcp|bootp]

tftp/dhcp linux pour booter un solaris sans jumpstart /rarp

  • /etc/xinetd.d/tftp
# default: off
# description: The tftp server serves files using the trivial file transfer \
#       protocol.  The tftp protocol is often used to boot diskless \
#       workstations, download configuration files to network-aware printers, \
#       and to start the installation process for some operating systems.
service tftp
{
        disable                 = no
        socket_type             = dgram
        protocol                = udp
        wait                    = yes
        user                    = root
        server                  = /usr/sbin/in.tftpd
        server_args             = -s /images/tftpboot
        per_source              = 11
        cps                     = 100 2
        flags                   = IPv4
}
  • Installer le package syslinux
  • Copier les fichiers ci-dessous de /usr/share/syslinux vers /images/tftpboot :
pxelinux.0
menu.c32
memdisk
mboot.c32
chain.c32
gpxelinux.0
  • /etc/dhcp/dhcpd.conf
allow booting;
allow bootp;

# Jumpstart Support
option space SUNW;
option SUNW.root-server-ip-address code 2 = ip-address;
option SUNW.root-server-hostname code 3 = text;
option SUNW.root-path-name code 4 = text;


host solaris10sparc {
# The MAC address for the machine we wish to boot
hardware ethernet 00:14:4f:af:9b:52;
fixed-address 10.1.239.143;
next-server 10.1.239.136;
filename "cristie_sol10_sparc/inetboot";
# Hostname or IP of the DHCP server (this machine)
server-name "10.1.239.136";
# Hostname to supply to the client
option host-name solaris10sparc;
# Indicate that we are using the SUNW options
vendor-option-space SUNW;
# Server location (that holds the NFS share)
option SUNW.root-server-hostname "pxe";
option SUNW.root-server-ip-address 10.1.239.136;
# Location of the system
option SUNW.root-path-name "/images/tftpboot/cristie_sol10_sparc/system/";
}
./system
./system/sparc.miniroot
./system/platform
./system/platform/sun4v
./system/platform/sun4v/boot_archive
./system/platform/sun4u
./system/platform/sun4u/boot_archive
./inetboot

La résolution DNS fonctionne mal

En Solaris 9 la résolution est OK :

root@machine:/# nslookup blababla-client.bidule.truc
Server:  dnserver.fr.net.intra
Address:  xxx.xx.xxx.xx

Non-authoritative answer:
Name:    vip-abc-abcd-rec.fr.net.intra
Address:  yy.yyy.yy.yy
Aliases:  blababla-client.bidule.truc.net.intra

En Solaris 10 cette même résolution ne fonctionne plus (le serveur DNS est toujours le même) :

root@machine:/etc# nslookup blababla-client.bidule.truc
Server:         xxx.xx.xxx.xx
Address:        xxx.xx.xxx.xx#53

** server can't find blababla-client.bidule.truct: NXDOMAIN

Il suffit de rajouter la ligne suivante à la fin du fichier /etc/resolv.conf :

options ndots:10

Si un nom d'hôte avec moins de ndots points était donné, search ajouterait chacun des domaines tour à tour au nom d'hôte, en essayant une requête avec chaque combinaison. Cette option vous permet de saisir un nom d'hôte non-qualifié; l'application détermine à partir de la liste fournie quel est l'organisme auquel cette machine appartient. Vous pouvez mentionner jusqu'à six domaines mais alors, les requêtes prendront beaucoup de temps. 1)

Activer / Désactiver une carte réseau

ifconfig bge0 down
ifconfig bge0 unplumb

Créer un alias réseau

Il faut avant tout renseigner les fichiers /etc/hosts et /etc/netmasks.

ifconfig bge0:1 plumb
ifconfig bge0:1 netmask + broadcast +
ifconfig bge0:1 up

Sinon on spécifier tout à la main :

ifconfig bge0:1 plumb
ifconfig bge0:1 netmask AAA.BBBB.CCC.DDD broadcast AAA.BBBB.CCC.DDD
ifconfig bge0:1 up

solaris 11, ssh, public key

FYI on Solaris 11 The default install sets root up as a role. This breaks ssh public key authentication for root as it always prompts for a password and the sshd server (in debug mode) always errors out with “Failed publickey for root from X.X.X.X port XXXX ssh2 debug 1.

The quick solution for the above is to set root back to a “normal” account type by running the following command (this edits the /etc/user_attr file):

rolemod -K type=normal root

  • informatique/nix/solaris/solaris_net.txt
  • Dernière modification : 2017/06/12 10:33
  • de 127.0.0.1